Technical Requirements

Please follow this guide of the technical requirements for installing Act! 

          bullet  Act! Pro v19 System (Technical) Requirements

          bullet  Act! Premium v19 (access via Windows®) System (Technical) Requirements

          bullet  Act! Premium v19 (access via web or mobile) System (Technical) Requirements

We do recommend that you get in touch with us first to discuss your requirements, to ensure Act! operates in an efficient environment. 

Contact us on 020 7831 3050 or email: info@CentrePointSoftware.co.uk


All minimum system requirements are based on a single-user environment (one computer accessing a local database), and do not represent requirements for optimum performance of your Act! implementation.  Customer registration and activation are required.  Your system must meet the minimum requirements to be eligible for technical support.


Act Connector

bullet  Act! Pro v19 System (Technical) Requirements
 

System Requirements1
       -  4GB available hard disk space2
       -  1280 x 768 or higher resolution monitor
       -  Broadband
Internet Connection
       -  2
GB system memory, 4 GB for 64-bit OS
       - 
1.8GHz processor
       -  Network Interface Card
       -  Microsoft Update Service must be current and running
 

Works With
       -  Microsoft® Office 2010, 2013, and 2016 (Latest Service Packs Recommended)
       - 
Internet Mail SMTP/POP33
       - 
Microsoft Internet Explorer® 11
       -  Google Chrome for Windows 

Supported Operated Systems4
       -  Windows Server 2016 (64-bit)5
       - 
Windows Server 2008 R2 (64-bit)6
       - 
Windows Server 2012 (64-bit)
       - 
Windows Server 2012 R2 (64-bit)
       - 
Windows Server 2011 SBS (64-bit)7
       - 
Windows 10 (32-bit and 64-bit)
       - 
Windows 8.1 (32-bit and 64-bit)
       - 
Windows 8.1 Pro (32-bit and 64-bit)
       - 
Windows 8.1 Enterprise (32-bit and 64-bit)
       -  Windows 7 SP1 (32-bit and 64-bit)
 

Database Server

Act! Pro uses SQL Server® 2014 Express or your existing installation of SQL Server 2008 R2 or newer8.  If you would like to use a different edition of SQL Server other than the one provided, please consult Microsoft documentation for specific requirements for that edition.


Act Companion

Recommended server system requirements are for environments of more than one user.  Customer registration and activation are required and you must purchase one license of Act! per user.

bullet  Act! Premium v19 (access via Windows®) System (Technical) Requirements 

System Requirements1
       -  4 GB available hard disk space2
       -  1280 x 768 or higher resolution monitor
       -  Broadband
Internet Connection
       -  2
GB system memory, 4 GB for 64-bit OS
       - 
1.8 GHz processor
       -  Microsoft Update Service must be current and running

Works With
       -  Microsoft® Office 2010, 2013, and 2016 (Latest Service Packs Recommended)

       - 
Internet Mail SMTP/POP33
       - 
Microsoft Internet Explorer® 11
       -  Google Chrome for Windows

Supported Operating Systems4
       -  Windows Server 2016 (64-bit)5
       - 
Windows Server 2008 R2 (64-bit)6
       - 
Windows Server 2012 (64-bit)
       - 
Windows Server 2012 R2 (64-bit)
       - 
Windows Server 2011 SBS (64-bit)7
       - 
Windows 10 (32-bit and 64-bit)
       - 
Windows 8.1 (32-bit and 64-bit)
       - 
Windows 8.1 Pro (32-bit and 64-bit)
       - 
Windows 8.1 Enterprise (32-bit and 64-bit)
       - 
Windows 7 SP1 (32-bit and 64-bit) 

Database Server

Act! Premium uses SQL Server® 2014 Express or your existing installation of SQL Server 2008 R2 or newer8.  If you would like to use a different edition of SQL Server other than the one provided, please consult Microsoft documentation for specific requirements for that edition.

 

Act reports

 

bullet  Act! Premium v19 (access via web or mobile) System (Technical) Requirements 

Server System Requirements1
       -  4
GB available hard disk space2
       - 
1280 x 768 or higher resolution monitor
       -  Broadband
Internet connection
       -  2
GB system memory, 4 GB for 64-bit OS
       - 
1.8 GHz processor
       -  Network Interface Card
       -  Router and/or Firewall that supports IPv4 NAT or IPv6

Supported Operating Systems4
       -  Windows Server 2016 (64-bit)5
       -  W
indows Server 2008 R2 (64-bit)6
       - 
Windows Server 2012 (64-bit)
       - 
Windows Server 2012 R2 (64-bit)
       - 
Windows Server 2011 SBS (64-bit)7
       -  
Windows 10 (32-bit and 64-bit)
       -  Windows 8.1 (32-bit and 64-bit)
       -  Windows 8.1 Pro (32-bit and 64-bit)
       - 
Windows 8.1 Enterprise (32-bit and 64-bit)
       -  Windows 7 SP1 (32-bit and 64-bit)

Database Server 

Act! Premium uses SQL Server® 2014 Express or your existing installation of SQL Server 2008 R2 or newer8.  If you would like to use a different edition of SQL Server other than the one provided, please consult Microsoft documentation, for specific requirements for that edition.

Supported Browsers
       -  Microsoft Internet Explorer® 11
       -  Google
Chrome™ Browser for Windows 

Supported Office Integrations
       -  Microsoft® Office 2010, 2013 and 2016 (Latest Service Packs Recommended)
       - 
Microsoft Word 2010, 2013 and 2016 (required for integration features only) (Latest Service Packs Recommended)
       - 
.NET 4.0 (required for integration features only) 

Mobile Client System Requirements
       - 
Safari® for iPad®
       - 
Safari® for iPhone®
       -  Google Chrome
™ Browser for Android
       -  Internet Access to Act! Premium for Web IIS server 

SQL Server Edition Recommendations 

SQL Express limits processor use to a single CPU but allowing multiple cores, memory used by SQL to 1 GB, and the size of your data file to 10GB.  For this reason, we recommend SQL Standard for any development over 20 users or 5 GB in size, allowing for growth.  Individual performance may vary based on actual database size, hardware variations, and product usage.

Contact 
Contact us on 020 7831 3050 to discuss your Act! requirements. 



Page break 

1Higher specification PCs and networks will improve performance, and may be recommended for certain Operating System Choices.  Consult Microsoft documentation for more details
2Additional disk space may be required as local database size increases
3SSL Secured Mail Services are not supported
4Anti-Virus products are recommended but should be disabled during install and re-enabled afterwards.  As with any Anti-Virus product, some configuration may be required for Act! to perform properly
5Windows Server 2016 support requires Act! v19.2
6Server Core installations of Windows Server 2008 R2 are not supported
7Only for supported for upgrades, not new/clean installations of Act!
8Microsoft SQL Server 2016 support requires Act! v19.2
  

 

Please register your details to start your free trial of Sage